Sedimetrics® Digital Gravelometer™ documentation (version 1.0)

File types

File types specific to Digital Gravelometer

Digital Gravelometer creates files with several different file extensions.

*.dgp

Digital Gravelometer project file. These binary files contain information about the project, the images it contains, the grain measurements made and the processing options selected in making the measurements. Create, open, close, save and edit the properties of project files from the File menu.

*.dgl

Digital Gravelometer lens parameters file. These binary files contain the radial lens correction parameters for particular cameras. Create and edit lens parameters files from the File > Lens Correction Parameters... menu.

*.dgt

Digital Gravelometer template file. These binary files contain templates describing which information to include in the grain-size reports generated by the software. Create and load template files from the Report options dialogue accessed from the Report menu.

^ top

Image file types used by Digital Gravelometer

*.jpg

JPEG (Joint Photographic Experts Group; pronounced jay-peg) files are ideally suited to storing digital photographs because they can store 24-bit (16 million colour) images with a high level of compression without any significant loss in quality being perceived by the human eye. For these reasons, most digital cameras export photographs in JPEG format. Most of the reduction in size is achieved by compressing the hue (colour) and saturation (vibrancy) information. Digital Gravelometer discards this information and only uses the intensity information in the image. Nevertheless, the compression does result in some loss of intensity information, and images to be analysed with Digital Gravelometer should be saved with the minimum level of compression supported by the camera. Repeatedly opening and saving the same image will result in a progressive loss of quality, so this should be avoided. JPEG is not appropriate for storing binary (black and white) images because the edges will become slightly blurred. Digital Gravelometer can read JPEG files and saves the grayscale intermediate stages in the grain-measurement procedure as JPEG by default. A comprehensive FAQs list on JPEG is at http://www.faqs.org/faqs/jpeg-faq/.

*.bmp

Windows Bitmap files may be used to store any type of image without compression and is widely supported by Windows applications. Because no compression is used, file sizes are generally large. Digital Gravelometer provides the option of saving intermediate stages in the grain-measurement procedure as Windows Bitmap files.

*.tif

TIFF (Tag Image File Format) is a flexible format that may be used to store any type of image either with or without compression. Some cameras are capable of exporting images as TIFF, and these are most likely to be uncompressed resulting in large file sizes. Digital Gravelometer can read TIFF image files and can save intermediate stages in the grain-measurement procedure as uncompressed TIFF. A basic description of TIFF is available at Wikipedia.

*.png

PNG (Portable Network Graphics; pronounced ping) files are compressed using a lossless algorithm and are becoming increasingly common on the internet. PNG may be used to save 24-bit (full colour) images (such as digital photographs), but the file sizes are large compared to JPEG. PNG is ideally suited to storing binary (black and white) images. Digital Gravelometer saves the binary intermediate stages in the grain-measurement procedure as PNG be default. Information about PNG is available at the PNG Home Site.

^ top

Other file types used by Digital Gravelometer

*.csv

Comma Separated Variable file. These are text (ASCII) files containing lists of items separated by commas. CSV files provide a convenient method of exporting data from Digital Gravelometer to other software, are widely supported by data analysis packages (including Microsoft® Excel), and may also be opened using any text editor or word processor. Digital Gravelometer offers the ability to output both the raw grain-size information (from the Export Data menu) and a complete analysis of the parameters of the grain-size distribution (from the Report menu).

^ top

Please report software bugs or documentation errors to bugs@sedimetrics.com
Visit Sedimetrics.com | © 2005-6 Loughborough University Enterprises Limited